aboutsummaryrefslogtreecommitdiff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorMalte Brandy <malte.brandy@maralorn.de>2020-10-14 01:46:17 +0200
committerMalte Brandy <malte.brandy@maralorn.de>2020-10-14 01:46:17 +0200
commitcebf9198f3fe80fa38a8c57eb3b02ac4c1df3e8a (patch)
treea63c3fb3954ecfd407aa649f777f102a262a4ddb /lib/types.nix
parent74d875206a825007e27abaa7c590f4c1db35ad31 (diff)
treewide: De-inline uses of lib.boolToString
This commit should not change eval results
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index e9e45dc25c72..30b053db486f 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -499,7 +499,7 @@ rec {
show = v:
if builtins.isString v then ''"${v}"''
else if builtins.isInt v then builtins.toString v
- else if builtins.isBool v then if v then "true" else "false"
+ else if builtins.isBool v then boolToString v
else ''<${builtins.typeOf v}>'';
in
mkOptionType rec {