aboutsummaryrefslogtreecommitdiff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-01-12 15:14:08 -0500
committerworldofpeace <worldofpeace@protonmail.ch>2020-01-12 15:14:08 -0500
commit265da70e583672311b8cfc998b550a2c5f9161ad (patch)
tree9ba9d1a4c72b46fe23ad0b5c181afa791c88bf9c /lib/types.nix
parent39096c5871c0cc11c1ef352647a5e65e36583ac6 (diff)
lib/types: dont warn loaOf for home-manager namespace
This option namespace is not a part of NixOS so we shouldn't provide this warning for it.
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/lib/types.nix b/lib/types.nix
index ab325fd20091..57ddb45a2371 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -367,18 +367,6 @@ rec {
{ path = [ "services" "geoclue2" "appConfig" ];
name = "desktopID";
}
- { path = [ "home-manager" "users" anyString "programs" "ssh" "matchBlocks" ];
- name = "host"; # https://github.com/rycee/home-manager/blob/e8dbc3561373b68d12decb3c0d7c1ba245f138f7/modules/programs/ssh.nix#L265
- }
- { path = [ "home-manager" "users" anyString "home" "file" ];
- name = "target"; # https://github.com/rycee/home-manager/blob/0e9b7aab3c6c27bf020402e0e2ef20b65c040552/modules/files.nix#L33
- }
- { path = [ "home-manager" "users" anyString "xdg" "configFile" ];
- name = "target"; # https://github.com/rycee/home-manager/blob/54de0e1d79a1370e57a8f23bef89f99f9b92ab67/modules/misc/xdg.nix#L41
- }
- { path = [ "home-manager" "users" anyString "xdg" "dataFile" ];
- name = "target"; # https://github.com/rycee/home-manager/blob/54de0e1d79a1370e57a8f23bef89f99f9b92ab67/modules/misc/xdg.nix#L58
- }
];
matched = let
equals = a: b: b == anyString || a == b;