aboutsummaryrefslogtreecommitdiff
path: root/lib/trivial.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2020-01-20 00:44:07 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2020-01-20 00:53:44 +0100
commit46773a15b3af302c3fb2a6e31fb589553a903099 (patch)
treee114d7663484ab94f159082a4095f2e95d198f4f /lib/trivial.nix
parent21f74cc3aba4dd4c8540b35f8cd0873bef15a2d6 (diff)
nixos/version: fix case where .git is a symlink
Before c9214c394b248e1f26e45dbe1be2bd82363af3a6 and 9d396d2e426b9a765de0b8999aa214f1259633e6 if .git is symlink the version would gracefully default to no git revision. With those changes an exception is thrown instead. This introduces a new function `pathIsGitRepo` that checks if `commitIdFromGitRepo` fails without error so we don't have to reimplement this logic again and can fail gracefully.
Diffstat (limited to 'lib/trivial.nix')
-rw-r--r--lib/trivial.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/trivial.nix b/lib/trivial.nix
index 940ec1a3d59e..a281cd70fb0e 100644
--- a/lib/trivial.nix
+++ b/lib/trivial.nix
@@ -191,7 +191,7 @@ rec {
let
revisionFile = "${toString ./..}/.git-revision";
gitRepo = "${toString ./..}/.git";
- in if builtins.pathExists gitRepo
+ in if lib.pathIsGitRepo gitRepo
then lib.commitIdFromGitRepo gitRepo
else if lib.pathExists revisionFile then lib.fileContents revisionFile
else default;