aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/systems.nix
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-04-24 20:12:43 -0400
committerJohn Ericson <Ericson2314@Yahoo.com>2017-05-17 11:14:59 -0400
commit296753f0947427d5753be68ae10363ac1b8b4cdc (patch)
tree599ad9bb98506efbb21982310bee9d062a7b26a1 /lib/tests/systems.nix
parent9c90ff7e7df9ceadc7335bb43cc67ba92e171d53 (diff)
lib: Consolidate tests into one meta job
Diffstat (limited to 'lib/tests/systems.nix')
-rw-r--r--lib/tests/systems.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/lib/tests/systems.nix b/lib/tests/systems.nix
index 5eacc0defafb..523fd3feb3b0 100644
--- a/lib/tests/systems.nix
+++ b/lib/tests/systems.nix
@@ -5,13 +5,13 @@
# calculating the lists anyway?". The answer is one can mindlessly update these
# tests as new platforms become supported, and then just give the diff a quick
# sanity check before committing :).
-{ lib, assertTrue }:
-
-with lib.systems.doubles;
-
-let mseteq = x: y: lib.sort lib.lessThan x == lib.sort lib.lessThan y; in
-
-{
+let
+ lib = import ../default.nix;
+ mseteq = x: y: {
+ expr = lib.sort lib.lessThan x;
+ expected = lib.sort lib.lessThan y;
+ };
+in with lib.systems.doubles; lib.runTests {
all = assertTrue (mseteq all (linux ++ darwin ++ cygwin ++ freebsd ++ openbsd ++ netbsd ++ illumos));
arm = assertTrue (mseteq arm [ "armv5tel-linux" "armv6l-linux" "armv7l-linux" ]);