aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/modules/types-anything/nested-attrs.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <contact@infinisil.com>2020-09-04 15:27:26 +0200
committerSilvan Mosberger <contact@infinisil.com>2020-09-15 21:06:05 +0200
commit6a7d250007baedeb4de34e8ce490d49160cb63a8 (patch)
tree482da5dd8e8bee9e53ee66a72a9aea1048bfdd8b /lib/tests/modules/types-anything/nested-attrs.nix
parent67551f46fbc20b3b96ff27503b659a8f3fedb421 (diff)
lib/tests: Add tests for types.anything
Diffstat (limited to '')
-rw-r--r--lib/tests/modules/types-anything/nested-attrs.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/tests/modules/types-anything/nested-attrs.nix b/lib/tests/modules/types-anything/nested-attrs.nix
new file mode 100644
index 000000000000..e57d33ef8717
--- /dev/null
+++ b/lib/tests/modules/types-anything/nested-attrs.nix
@@ -0,0 +1,22 @@
+{ lib, ... }: {
+
+ options.value = lib.mkOption {
+ type = lib.types.anything;
+ };
+
+ config = lib.mkMerge [
+ {
+ value.foo = null;
+ }
+ {
+ value.l1.foo = null;
+ }
+ {
+ value.l1.l2.foo = null;
+ }
+ {
+ value.l1.l2.l3.foo = null;
+ }
+ ];
+
+}