aboutsummaryrefslogtreecommitdiff
path: root/lib/systems/parse.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-10-12 15:09:59 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2018-10-29 14:34:09 -0500
commitd59a9ac7cf5e17f42aa1d971028f108864f2d252 (patch)
treeb6a8dd275ba5fdcb10b2d8c1cc0c5c004702ffe0 /lib/systems/parse.nix
parent075e4883e0abea400aecb886e6244a6c2acf7bd8 (diff)
avr: use new compilation infrastructure
Gets rid of: avrbinutils avrgcc to replace with: pkgsCross.avr.buildPackages.binutils pkgsCross.avr.buildPackages.gcc
Diffstat (limited to 'lib/systems/parse.nix')
-rw-r--r--lib/systems/parse.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/systems/parse.nix b/lib/systems/parse.nix
index bb26c93f3d7a..058d4bed9085 100644
--- a/lib/systems/parse.nix
+++ b/lib/systems/parse.nix
@@ -101,6 +101,8 @@ rec {
wasm32 = { bits = 32; significantByte = littleEndian; family = "wasm"; };
wasm64 = { bits = 64; significantByte = littleEndian; family = "wasm"; };
+
+ avr = { bits = 8; family = "avr"; };
};
################################################################################
@@ -255,6 +257,9 @@ rec {
setType "system" components;
mkSkeletonFromList = l: {
+ "1" = if elemAt l 0 == "avr"
+ then { cpu = elemAt l 0; kernel = "none"; abi = "unknown"; }
+ else throw "Target specification with 1 components is ambiguous";
"2" = # We only do 2-part hacks for things Nix already supports
if elemAt l 1 == "cygwin"
then { cpu = elemAt l 0; kernel = "windows"; abi = "cygnus"; }