aboutsummaryrefslogtreecommitdiff
path: root/lib/systems/parse.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-11 17:35:56 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-11 19:03:07 -0400
commit28bacc2093a43c21f34a192397d2b2561a9fd29d (patch)
tree5ecfa33792ae09eb62a62295600979377769dbba /lib/systems/parse.nix
parentf4de66977749f733b9a13d5f03550960ff800b0b (diff)
lib/systems: Add assertion to "android" ABI
This is analogous to the GNU assertion.
Diffstat (limited to 'lib/systems/parse.nix')
-rw-r--r--lib/systems/parse.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/systems/parse.nix b/lib/systems/parse.nix
index 02ca3a6b3614..3dba5ad46984 100644
--- a/lib/systems/parse.nix
+++ b/lib/systems/parse.nix
@@ -199,8 +199,16 @@ rec {
msvc = {};
eabi = {};
- androideabi = {};
- android = {};
+ androideabi = { float = "hard"; };
+ android = {
+ assertions = [
+ { assertion = platform: !platform.isAarch32;
+ message = ''
+ The "android" ABI is not for 32-bit ARM. Use "androideabi" instead.
+ '';
+ }
+ ];
+ };
gnueabi = { float = "soft"; };
gnueabihf = { float = "hard"; };