aboutsummaryrefslogtreecommitdiff
path: root/lib/systems/examples.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-01-29 21:01:24 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2019-04-23 21:48:57 -0400
commit9abff4af4f07c16aecd89bf82051afbc3228d6fd (patch)
tree7a8d8fe316db1636819a43a28192da740ea835c8 /lib/systems/examples.nix
parent6088a4793f2a83921b197a9185034934fcd96d02 (diff)
wasm: init cross target
Adds pkgsCross.wasm32 and pkgsCross.wasm64. Use it to build Nixpkgs with a WebAssembly toolchain. stdenv/cross: use static overlay on isWasm isWasm doesn’t make sense dynamically linked.
Diffstat (limited to 'lib/systems/examples.nix')
-rw-r--r--lib/systems/examples.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/lib/systems/examples.nix b/lib/systems/examples.nix
index 1a5b80449bf2..94c7cfd7570f 100644
--- a/lib/systems/examples.nix
+++ b/lib/systems/examples.nix
@@ -116,7 +116,7 @@ rec {
config = "aarch64-none-elf";
libc = "newlib";
};
-
+
aarch64be-embedded = {
config = "aarch64_be-none-elf";
libc = "newlib";
@@ -126,7 +126,7 @@ rec {
config = "powerpc-none-eabi";
libc = "newlib";
};
-
+
ppcle-embedded = {
config = "powerpcle-none-eabi";
libc = "newlib";
@@ -211,4 +211,14 @@ rec {
config = "x86_64-unknown-netbsd";
libc = "nblibc";
};
+
+ #
+ # WASM
+ #
+
+ wasi32 = {
+ config = "wasm32-unknown-wasi";
+ useLLVM = true;
+ };
+
}