aboutsummaryrefslogtreecommitdiff
path: root/lib/strings.nix
diff options
context:
space:
mode:
authorNathan van Doorn <nvd1234@gmail.com>2019-03-18 12:14:39 +0000
committerGitHub <noreply@github.com>2019-03-18 12:14:39 +0000
commit8bf42f538e562bf6dac8affeab8b2c9c62a0d839 (patch)
tree4c862e1dd6d0ab731c4b6d7cb0a7bf77f1e32c96 /lib/strings.nix
parentb16f32acd426d6942e57ab59a999ad22aee5c62a (diff)
Doc fix: use correct function name in type signature for concatIMapStringsSep
Diffstat (limited to 'lib/strings.nix')
-rw-r--r--lib/strings.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/strings.nix b/lib/strings.nix
index 47c881cfbc7c..ae0d74c6721d 100644
--- a/lib/strings.nix
+++ b/lib/strings.nix
@@ -90,7 +90,7 @@ rec {
/* Same as `concatMapStringsSep`, but the mapping function
additionally receives the position of its argument.
- Type: concatMapStringsSep :: string -> (int -> string -> string) -> [string] -> string
+ Type: concatIMapStringsSep :: string -> (int -> string -> string) -> [string] -> string
Example:
concatImapStringsSep "-" (pos: x: toString (x / pos)) [ 6 6 6 ]