aboutsummaryrefslogtreecommitdiff
path: root/lib/options.nix
diff options
context:
space:
mode:
authorDanylo Hlynskyi <abcz2.uprola@gmail.com>2019-03-07 21:28:09 +0200
committerGitHub <noreply@github.com>2019-03-07 21:28:09 +0200
commit60e8fcf0e56ce881294b06bd1f40069016308162 (patch)
tree15d4e83548173c9ae881e42e6557573864b68a3b /lib/options.nix
parentcf1de3c2df3d4ca558e81a62ba475ab8a4d9fce6 (diff)
module system: revert "remove types.optionSet", just deprecate (#56857)
The explicit remove helped to uncover some hidden uses of `optionSet` in NixOps. However it makes life harder for end-users of NixOps - it will be impossible to deploy 19.03 systems with old NixOps, but there is no new release of NixOps with `optionSet` fixes. Also, "deprecation" process isn't well defined. Even that `optionSet` was declared "deprecated" for many years, it was never announced. Hence, I leave "deprecation" announce. Then, 3 releases after announce, we can announce removal of this feature. This type has to be removed, not `throw`-ed in runtime, because it makes some perfectly fine code to fail. For example: ``` $ nix-instantiate --eval -E '(import <nixpkgs/lib>).types' --strict trace: `types.list` is deprecated; use `types.listOf` instead error: types.optionSet is deprecated; use types.submodule instead (use '--show-trace' to show detailed location information) ```
Diffstat (limited to 'lib/options.nix')
-rw-r--r--lib/options.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/options.nix b/lib/options.nix
index d46dec6e41ca..a16a980398d6 100644
--- a/lib/options.nix
+++ b/lib/options.nix
@@ -48,6 +48,8 @@ rec {
visible ? null,
# Whether the option can be set only once
readOnly ? null,
+ # Deprecated, used by types.optionSet.
+ options ? null
} @ attrs:
attrs // { _type = "option"; };