aboutsummaryrefslogtreecommitdiff
path: root/lib/deprecated.nix
diff options
context:
space:
mode:
authorEmily <vcs@emily.moe>2020-05-11 23:04:41 +0100
committerEmily <vcs@emily.moe>2020-05-11 23:11:12 +0100
commitaff997917095e5e006624eaf8de3f1cd3c52f256 (patch)
tree323f1b7255c56069a10c5945c880a620d3f8a543 /lib/deprecated.nix
parent346de1fb8c3273ea74a0d15ff0580b0d6610a476 (diff)
lib.fake{Sri => Hash}: fix and rename
The previous hash was too short and caused evaluation-time errors like: invalid SRI hash 'sha256-AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=' Additionally, since the fact that this is broken implies that nobody could have been using it, "SRI" is a bit of a vague and obscure term, `fakeSriHash` would be somewhat of a mouthful, and the relevant fetcher parameters are just called `hash`, rename it to `fakeHash`.
Diffstat (limited to 'lib/deprecated.nix')
-rw-r--r--lib/deprecated.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/deprecated.nix b/lib/deprecated.nix
index 8c4fe9c390c6..be0ef904c66d 100644
--- a/lib/deprecated.nix
+++ b/lib/deprecated.nix
@@ -272,7 +272,7 @@ rec {
imap = imap1;
# Fake hashes. Can be used as hash placeholders, when computing hash ahead isn't trivial
- fakeSri = "sha256-AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=";
+ fakeHash = "sha256-AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=";
fakeSha256 = "0000000000000000000000000000000000000000000000000000000000000000";
fakeSha512 = "00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000";
}