aboutsummaryrefslogtreecommitdiff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2018-08-08 19:26:52 +0200
committerProfpatsch <mail@profpatsch.de>2018-09-06 18:14:27 +0200
commitefdf618330a22f837f0e5e446028e918a5b4dd8a (patch)
tree6b9ad4353a2e470a3bccbbdca89247047263062b /lib/default.nix
parent3e45b61a9920466a8ea06b8ad9350d56ade435bc (diff)
lib: move assertMsg and assertOneOf to their own library file
Since the `assertOneOf` uses `lib.generators`, they are not really trivial anymore and should go into their own library file.
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 358c8ca0b8f9..d7a05fec8338 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -38,10 +38,11 @@ let
systems = callLibs ./systems;
# misc
+ asserts = callLibs ./asserts.nix;
debug = callLibs ./debug.nix;
-
generators = callLibs ./generators.nix;
misc = callLibs ./deprecated.nix;
+
# domain-specific
fetchers = callLibs ./fetchers.nix;
@@ -59,9 +60,7 @@ let
inherit (trivial) id const concat or and bitAnd bitOr bitXor bitNot
boolToString mergeAttrs flip mapNullable inNixShell min max
importJSON warn info nixpkgsVersion version mod compare
- splitByAndCompare functionArgs setFunctionArgs isFunction
- assertMsg assertOneOf;
-
+ splitByAndCompare functionArgs setFunctionArgs isFunction;
inherit (fixedPoints) fix fix' extends composeExtensions
makeExtensible makeExtensibleWithCustomName;
inherit (attrsets) attrByPath hasAttrByPath setAttrByPath
@@ -118,6 +117,8 @@ let
unknownModule mkOption;
inherit (types) isType setType defaultTypeMerge defaultFunctor
isOptionType mkOptionType;
+ inherit (asserts)
+ assertMsg assertOneOf;
inherit (debug) addErrorContextToAttrs traceIf traceVal traceValFn
traceXMLVal traceXMLValMarked traceSeq traceSeqN traceValSeq
traceValSeqFn traceValSeqN traceValSeqNFn traceShowVal