aboutsummaryrefslogtreecommitdiff
path: root/lib/customisation.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2019-02-03 15:30:15 +0000
committerJan Malakhovski <oxij@oxij.org>2019-02-03 15:30:15 +0000
commit51687d9a7fdce50d46d75f16e2dffac148141305 (patch)
treefc5f25b69f9c105c5882c0e349198ea042c6a174 /lib/customisation.nix
parent107f0fc9e712996674ce7f67ac4d2e6163f88822 (diff)
lib: tiny cleanup
Diffstat (limited to 'lib/customisation.nix')
-rw-r--r--lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/customisation.nix b/lib/customisation.nix
index 68062dd0daf0..1f5eb0d11e8b 100644
--- a/lib/customisation.nix
+++ b/lib/customisation.nix
@@ -121,7 +121,7 @@ rec {
auto = builtins.intersectAttrs (lib.functionArgs f) autoArgs;
origArgs = auto // args;
pkgs = f origArgs;
- mkAttrOverridable = name: pkg: makeOverridable (newArgs: (f newArgs).${name}) origArgs;
+ mkAttrOverridable = name: _: makeOverridable (newArgs: (f newArgs).${name}) origArgs;
in lib.mapAttrs mkAttrOverridable pkgs;