aboutsummaryrefslogtreecommitdiff
path: root/lib/customisation.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2018-07-12 02:04:06 +0200
committerSilvan Mosberger <infinisil@icloud.com>2018-07-12 02:04:06 +0200
commit4794aa5de233b5bf2d1c3245946379699d023467 (patch)
treec50d5c56b29dcd3b567038f4a8e87d8c41ba5d23 /lib/customisation.nix
parentb84e951f92207a985c9c7717b6a6853c72112345 (diff)
Revert "lib: Use lib.fixed-points.extends to avoid repetition"
This reverts commit 48ccdf322d9e7a68d0caf5833511ee3e53ec7d3a.
Diffstat (limited to 'lib/customisation.nix')
-rw-r--r--lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/customisation.nix b/lib/customisation.nix
index 9017319420c8..d942f54ee798 100644
--- a/lib/customisation.nix
+++ b/lib/customisation.nix
@@ -202,7 +202,7 @@ rec {
callPackage = self.newScope {};
overrideScope = g:
makeScope newScope
- (lib.fixed-points.extends f g);
+ (self_: let super = f self_; in super // g super self_);
packages = f;
};
in self;