aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/emacs/default.nix
diff options
context:
space:
mode:
authorMx Kookie <kookie@spacekookie.de>2020-12-21 06:23:30 +0100
committerMx Kookie <kookie@spacekookie.de>2020-12-21 06:23:30 +0100
commit89f641be1a2b7eac883b15b98100ca70c6c87e7c (patch)
treefca567200e2566a299610c8fd5e1e047039a3f24 /infra/libkookie/modules/workstation/emacs/default.nix
parent75d90de7bdc53f77c96c351d84891606b16e9c3e (diff)
code dumptmp
Diffstat (limited to 'infra/libkookie/modules/workstation/emacs/default.nix')
-rw-r--r--infra/libkookie/modules/workstation/emacs/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/infra/libkookie/modules/workstation/emacs/default.nix b/infra/libkookie/modules/workstation/emacs/default.nix
new file mode 100644
index 000000000000..57949cb333b7
--- /dev/null
+++ b/infra/libkookie/modules/workstation/emacs/default.nix
@@ -0,0 +1,18 @@
+/**
+ * A custom wrapper module to configure an emacs installation.
+ *
+ */
+
+{ config, lib, pkgs, home-manager, options, ...} @ args:
+
+let cfg = config.libkookie.emacs;
+in
+with lib;
+{
+ options.libkookie.emacs = {
+ enable = mkEnableOption "emacs configuration module";
+ };
+
+ config = (lib.trace args.options {}); # (import ./core.nix args);
+}
+