aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/configuration/base/shell/default.nix
diff options
context:
space:
mode:
authorMx Kookie <kookie@spacekookie.de>2020-12-23 02:19:40 +0100
committerMx Kookie <kookie@spacekookie.de>2020-12-23 02:21:20 +0100
commitd0b1a2d3e90f72380d101f10d4caae2a750986b5 (patch)
treeea72175345ff6551671ee5315f43c4ef961dfa90 /infra/libkookie/configuration/base/shell/default.nix
parente39465caf3293f56d0a9bccee599ea3f902fc2b2 (diff)
libkookie: base: init module with shell tools, git, and fish support
Diffstat (limited to '')
-rw-r--r--infra/libkookie/configuration/base/shell/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/infra/libkookie/configuration/base/shell/default.nix b/infra/libkookie/configuration/base/shell/default.nix
new file mode 100644
index 000000000000..32a37330c3f0
--- /dev/null
+++ b/infra/libkookie/configuration/base/shell/default.nix
@@ -0,0 +1,34 @@
+/* ADDITIONAL SHELL TOOLS
+ *
+ * This module is a bit hard to wrap your head around, not because of
+ * what it does but because of the classification of tools it
+ * contains. It's a list of various utilities that are super useful
+ * for day-to-day use, but it's difficult to avoid just having one
+ * large file that contains _all_ applications you would ever use.
+ *
+ * Only add stuff to this list if you're sure that it will be useful
+ * on ALL workstations, as well as root-servers and user-servers!
+ */
+
+{ pkgs, ... }:
+
+{
+ home-manager.users.spacekookie = { ... }: {
+ home.packages = with pkgs; [
+ bat
+ curl
+ fzf
+ htop
+ kakoune # used to have a vim-type editor everywhere
+ moreutils
+ pciutils
+ pv
+ ripgrep
+ skim
+ tmux
+ tree
+ usbutils
+ wget
+ ];
+ };
+}