aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/shell.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-06 22:54:28 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-06 22:54:28 +0100
commita6a1949914fb2074fb5fec9c75b075eac369541f (patch)
treea112f4ce0e88298c1d8a25c504d7a0478a0c39dc /games/rstnode/shell.nix
parentcf9392a33bb99ae581f818d3ddb8be1231521a02 (diff)
rstnode: create small graphics example
Diffstat (limited to 'games/rstnode/shell.nix')
-rw-r--r--games/rstnode/shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/rstnode/shell.nix b/games/rstnode/shell.nix
index 98465394e67e..207d5ef3cd33 100644
--- a/games/rstnode/shell.nix
+++ b/games/rstnode/shell.nix
@@ -1,7 +1,7 @@
with import <nixpkgs> {};
-stdenv.mkDerivation {
- name = "rstnode";
+mkShell rec {
+ name = "rstnode-shell";
buildInputs = with pkgs; [
rustc cargo clangStdenv rust-analyzer rustfmt
alsaLib pkg-config libudev
@@ -18,4 +18,6 @@ stdenv.mkDerivation {
libxcb
libxkbcommon
]);
+
+ LD_LIBRARY_PATH = (lib.makeLibraryPath buildInputs);
}