aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/rst-core/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-06 19:40:53 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-06 19:42:04 +0100
commitcf9392a33bb99ae581f818d3ddb8be1231521a02 (patch)
tree8295d8a4ed199c3263eadd8f1a508b98567a44f7 /games/rstnode/rst-core/Cargo.toml
parent56d96b2f22bf6a61ff992b000215dc3a2c2448ad (diff)
rstnode: restructure project into workspace and sub-crates
Diffstat (limited to '')
-rw-r--r--games/rstnode/rst-core/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/rstnode/rst-core/Cargo.toml b/games/rstnode/rst-core/Cargo.toml
new file mode 100644
index 000000000000..da0d3fa0ad55
--- /dev/null
+++ b/games/rstnode/rst-core/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "rst-core"
+description = "Shared logic and type state library for rstnode"
+version = "0.0.0"
+edition = "2018"
+license = "AGPL-3.0-or-later"
+authors = ["Bread Machine", "Katharina Fey <kookie@spacekookie.de>"]
+
+[dependencies]
+
+# Serialisation
+bincode = "1.0"
+serde = { version = "1.0", features = ["derive", "rc"] }
+serde_yaml = "0.8.15"
+
+# Async utils
+async-std = { version = "1.0", features = ["unstable"] }
+async-trait = "0.1"
+
+# Ratman networking utils
+identity = { version = "0.4", features = ["random"], package = "ratman-identity"}
+netmod-mem = "0.1.0"
+ratman = "0.1"
+
+# Other dependencies
+chrono = { version = "0.4", features = ["serde"] }
+const_env = "0.1"
+quadtree_rs = "0.1"
+rand = "0.7"