aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/rst-client/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-07 16:44:44 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-07 16:44:44 +0100
commit79c8b9ab441493e3b3a37a59263f66896c9c90b3 (patch)
treeca111686fa202369a5730ff8151480b04e391cbb /games/rstnode/rst-client/Cargo.toml
parentf5b36ff6b99256030201c878608a07d163b4c802 (diff)
rstnode: basic asset loading and prototype sprite rendering
* restructure assets directory * implement asset loading and dynamic conversion to sprites * reload sprites with unique URIs to load at runtime * provide an updated renderer API to give access to client state * use new APIs to draw a single node frame on screen * use colour APIs to dynamically change node frame colour
Diffstat (limited to 'games/rstnode/rst-client/Cargo.toml')
-rw-r--r--games/rstnode/rst-client/Cargo.toml11
1 files changed, 8 insertions, 3 deletions
diff --git a/games/rstnode/rst-client/Cargo.toml b/games/rstnode/rst-client/Cargo.toml
index 929f7550bbef..7b5155f8108c 100644
--- a/games/rstnode/rst-client/Cargo.toml
+++ b/games/rstnode/rst-client/Cargo.toml
@@ -9,8 +9,13 @@ authors = ["Bread Machine", "Katharina Fey <kookie@spacekookie.de>"]
[dependencies]
rst-core = { path = "../rst-core" }
-clap = "2.0"
+cairo-rs = { version="0.8.0", features=["v1_16", "png", "svg"] }
+librsvg = { git = "https://gitlab.gnome.org/GNOME/librsvg.git", rev = "d34f570f" }
ggez = "0.6.0-rc0"
mint = "0.5" # Required because ggez is trash
-librsvg = { git = "https://gitlab.gnome.org/GNOME/librsvg.git", rev = "d34f570f" }
-cairo-rs = { version="0.8.0", features=["v1_16", "png", "svg"] } \ No newline at end of file
+svg = "0.9"
+
+clap = "2.0"
+tracing = "0.1"
+tracing-subscriber = "0.2"
+tempfile = "*" \ No newline at end of file