aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-01-29 11:25:05 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-01-29 11:25:05 +0100
commit31ec889558d6a32d4861d7d14eff1f559e7ca72c (patch)
treec9bb875698d6ee3544eef864ddec2c9db561707f /games/rstnode/Cargo.toml
parent9765d1e42dc9d1d3a90f54d87cebdd7ab4549417 (diff)
parent78d813b2a119b314349555387669f9c33727c5b1 (diff)
Add 'games/rstnode/' from commit '78d813b2a119b314349555387669f9c33727c5b1'
git-subtree-dir: games/rstnode git-subtree-mainline: 9765d1e42dc9d1d3a90f54d87cebdd7ab4549417 git-subtree-split: 78d813b2a119b314349555387669f9c33727c5b1
Diffstat (limited to 'games/rstnode/Cargo.toml')
-rw-r--r--games/rstnode/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/rstnode/Cargo.toml b/games/rstnode/Cargo.toml
new file mode 100644
index 000000000000..c62fd1354e38
--- /dev/null
+++ b/games/rstnode/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "rstnode"
+description = "A game about capturing computers on a network"
+version = "0.0.0"
+edition = "2018"
+license = "AGPL-3.0-or-later"
+authors = ["Bread Machine", "Katharina Fey <kookie@spacekookie.de>"]
+
+[dependencies]
+serde = { version = "1.0", features = ["derive", "rc"] }
+serde_json = "1.0"
+async-std = { version = "1.0", features = ["unstable"] }
+async-trait = "0.1"
+
+ratman = "0.1.0"
+netmod-mem = "0.1.0"
+identity = { version = "0.4", features = ["random"], package = "ratman-identity"}
+
+ggez = "0.5"
+cgmath = { version = "*", features = ["mint"] }
+chrono = { version = "0.4", features = ["serde"] }
+rand = "0.7"
+quadtree_rs = "0.1"
+
+# [profile.release.overrides."*"]
+# opt-level = 3 \ No newline at end of file