aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorMilan Pässler <milan@petabyte.dev>2020-11-03 15:45:51 +0100
committerMilan Pässler <milan@petabyte.dev>2020-11-03 15:45:51 +0100
commitd5fe9ec7598dd8297388a415816a20493af53520 (patch)
tree72fb079a3f8d433b3ddc825cd171b2af7a819f2e /flake.nix
parent783026ab2d48a76db01f124c8d0ea3b23cf81720 (diff)
run nixfmt on everything
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix74
1 files changed, 33 insertions, 41 deletions
diff --git a/flake.nix b/flake.nix
index 0c56498ee605..6864f3840909 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,51 +7,43 @@
};
description = "A collections of derivations for coreboot and payloads";
- outputs = { self, nixpkgs }: let
- nixpkgsOptions = {
- system = "x86_64-linux";
- overlays = [
- (import ./pkgs/overlay.nix)
- ];
- };
- pkgs = import nixpkgs nixpkgsOptions;
- inherit (pkgs) lib;
+ outputs = { self, nixpkgs }:
+ let
+ nixpkgsOptions = {
+ system = "x86_64-linux";
+ overlays = [ (import ./pkgs/overlay.nix) ];
+ };
+ pkgs = import nixpkgs nixpkgsOptions;
+ inherit (pkgs) lib;
- makeDevice = configFile: (lib.evalModules {
- modules = [
- ({ ... }: {
- nixpkgs = nixpkgsOptions;
- })
- ("${nixpkgs}/nixos/modules/misc/assertions.nix")
- ("${nixpkgs}/nixos/modules/misc/nixpkgs.nix")
- ./modules
- configFile
- ];
- }).config.corenix.rom;
+ makeDevice = configFile:
+ (lib.evalModules {
+ modules = [
+ ({ ... }: { nixpkgs = nixpkgsOptions; })
+ ("${nixpkgs}/nixos/modules/misc/assertions.nix")
+ ("${nixpkgs}/nixos/modules/misc/nixpkgs.nix")
+ ./modules
+ configFile
+ ];
+ }).config.corenix.rom;
- exportedPkgs = {
- inherit (pkgs)
- coreboot
- coreboot-payload-grub2
- coreboot-payload-tianocore
- coreboot-payload-seabios
- coreboot-payload-tint
- coreboot-payload-nvramcui
- coreboot-payload-coreinfo;
+ exportedPkgs = {
+ inherit (pkgs)
+ coreboot coreboot-payload-grub2 coreboot-payload-tianocore
+ coreboot-payload-seabios coreboot-payload-tint
+ coreboot-payload-nvramcui coreboot-payload-coreinfo;
- milan-x1c = makeDevice ./configs/milan/milan-x1c.nix;
- milan-x230t = makeDevice ./configs/milan/milan-x230t.nix;
- milan-x230-fhd = makeDevice ./configs/milan/milan-x230-fhd.nix;
- };
+ milan-x1c = makeDevice ./configs/milan/milan-x1c.nix;
+ milan-x230t = makeDevice ./configs/milan/milan-x230t.nix;
+ milan-x230-fhd = makeDevice ./configs/milan/milan-x230-fhd.nix;
+ };
- in {
- lib = {
- inherit makeDevice;
- };
+ in {
+ lib = { inherit makeDevice; };
- packages.x86_64-linux = exportedPkgs;
+ packages.x86_64-linux = exportedPkgs;
- # shortcut for use with flake-compat
- pkgs = exportedPkgs;
- };
+ # shortcut for use with flake-compat
+ pkgs = exportedPkgs;
+ };
}