aboutsummaryrefslogtreecommitdiff
path: root/doc/default.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-24 11:02:23 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-24 11:03:55 +0200
commit438b9c543d535f525ac50affd045bdf41a3239d6 (patch)
treee9c90dc09ce11309910a754cc39a5c66a7bda353 /doc/default.nix
parent14f48dd5c2c4f4f4a2409d4ced1dd4ca2cab5e74 (diff)
Nixpkgs manual: Add a Nix expression to build
Diffstat (limited to 'doc/default.nix')
-rw-r--r--doc/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/doc/default.nix b/doc/default.nix
new file mode 100644
index 000000000000..1e8974d60266
--- /dev/null
+++ b/doc/default.nix
@@ -0,0 +1,42 @@
+with import ./.. { };
+with lib;
+
+stdenv.mkDerivation {
+ name = "nixpkgs-manual";
+
+ sources = sourceFilesBySuffices ./. [".xml"];
+
+ buildInputs = [ libxml2 libxslt ];
+
+ xsltFlags = ''
+ --param section.autolabel 1
+ --param section.label.includes.component.label 1
+ --param html.stylesheet 'style.css'
+ --param xref.with.number.and.title 1
+ --param toc.section.depth 3
+ --param admon.style '''
+ --param callout.graphics.extension '.gif'
+ '';
+
+ buildCommand = ''
+ ln -s $sources/*.xml . # */
+
+ echo ${nixpkgsVersion} > .version
+
+ xmllint --noout --nonet --xinclude --noxincludenode \
+ --relaxng ${docbook5}/xml/rng/docbook/docbook.rng \
+ manual.xml
+
+ dst=$out/share/doc/nixpkgs
+ mkdir -p $dst
+ xsltproc $xsltFlags --nonet --xinclude \
+ --output $dst/manual.html \
+ ${docbook5_xsl}/xml/xsl/docbook/xhtml/docbook.xsl \
+ ./manual.xml
+
+ cp ${./style.css} $dst/style.css
+
+ mkdir -p $out/nix-support
+ echo "doc manual $dst manual.html" >> $out/nix-support/hydra-build-products
+ '';
+}