aboutsummaryrefslogtreecommitdiff
path: root/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
diff options
context:
space:
mode:
authorMx Kookie <kookie@spacekookie.de>2020-10-31 19:06:35 +0100
committerMx Kookie <kookie@spacekookie.de>2020-12-21 05:10:28 +0100
commit90a45a314f99c7b08f25a02efcee2a847685562b (patch)
treea3c15278adbda7d0a79dcc170340b501da01d847 /development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
parentf56286e4c490ea69163988742a90d4376a4db08e (diff)
Add 'development/tools/cargo-workspace2/' from commit 'c3e1e0679bae7aa6bd668125cb997812a590f875'
git-subtree-dir: development/tools/cargo-workspace2 git-subtree-mainline: ddeaea72333d8bb6911ac45fcfe40ee1caa00b04 git-subtree-split: c3e1e0679bae7aa6bd668125cb997812a590f875
Diffstat (limited to 'development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml')
-rw-r--r--development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml b/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
new file mode 100644
index 000000000000..91500336aafe
--- /dev/null
+++ b/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "lockchain-http"
+description = "Generic HTTP interface crate for the lockchain ecosystem. Can serve both encrypted and cleartext records"
+version = "0.4.1-alpha.0"
+authors = ["Katharina Fey <kookie@spacekookie.de>"]
+
+documentation = "https://docs.rs/lockchain-http"
+homepage = "https://github.com/spacekookie/lockchain/tree/master/lockchain-http"
+readme = "README.md"
+license = "MIT/X11 OR Apache-2.0"
+
+[dependencies]
+lockchain-core = { version = "0.9.1-alpha.0", path = "../lockchain-core" }
+env_logger = "0.5"
+
+# Serialisation stack
+serde = "1.0"
+serde_derive = "1.0"
+
+# Web Stack
+futures = "0.1"
+actix = "0.5"
+actix-web = "0.6" \ No newline at end of file