aboutsummaryrefslogtreecommitdiff
path: root/development/tools/cargo-workspace2/shell.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-18 21:29:54 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-18 21:29:54 +0100
commit837a0ca6438d1f78a7364c3c7c310dc96e01f31d (patch)
tree3e3289f4efe3f29bed7220bd4be9f4c0c18eaa28 /development/tools/cargo-workspace2/shell.nix
parent12a35f8969264c6acf8afa485cae03369d1d9eaf (diff)
cargo-workspace2: change repository link
Diffstat (limited to '')
-rw-r--r--development/tools/cargo-workspace2/shell.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/development/tools/cargo-workspace2/shell.nix b/development/tools/cargo-workspace2/shell.nix
index e055bd79d189..66c1429799cd 100644
--- a/development/tools/cargo-workspace2/shell.nix
+++ b/development/tools/cargo-workspace2/shell.nix
@@ -1,9 +1,8 @@
-with import <nixpkgs> {
- config.android_sdk.accept_license = true;
- config.allowUnfree = true;
-};
+with import <nixpkgs> {};
stdenv.mkDerivation {
name = "cargo-workspace2";
- buildInputs = with pkgs; [ clangStdenv ];
+ buildInputs = with pkgs; [
+ rustc cargo clangStdenv rust-analyzer rustfmt
+ ];
}