aboutsummaryrefslogtreecommitdiff
path: root/development/compilers/ocaml/3.11.1.nix
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2009-06-26 16:53:02 +0000
committerMarc Weber <marco-oweber@gmx.de>2009-06-26 16:53:02 +0000
commitf316832e3ace9cb417148d0fa6041d84c5ec765a (patch)
tree96c03f8a7a5903bff6ef18fc1e49ac34577f13e9 /development/compilers/ocaml/3.11.1.nix
parent3fa07803c62ce2b7dc984f10d0f7bd6e6b6b0948 (diff)
update default ocmal to 3.11.1. patch provided by olegfink
svn path=/nixpkgs/trunk/; revision=16061
Diffstat (limited to '')
-rw-r--r--development/compilers/ocaml/3.11.1.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/development/compilers/ocaml/3.11.1.nix b/development/compilers/ocaml/3.11.1.nix
new file mode 100644
index 000000000000..f5955c7c78c2
--- /dev/null
+++ b/development/compilers/ocaml/3.11.1.nix
@@ -0,0 +1,28 @@
+args: with args;
+
+stdenv.mkDerivation (rec {
+
+ name = "ocaml-3.11.1";
+
+ src = fetchurl {
+ url = "http://caml.inria.fr/pub/distrib/ocaml-3.11/${name}.tar.bz2";
+ sha256 = "8c36a28106d4b683a15c547dfe4cb757a53fa9247579d1cc25bd06a22cc62e50";
+ };
+
+ prefixKey = "-prefix ";
+ configureFlags = ["-no-tk" "-x11lib" x11];
+ buildFlags = "world bootstrap world.opt";
+ buildInputs = [x11 ncurses];
+ installTargets = "install installopt";
+ patchPhase = ''
+ CAT=$(type -tp cat)
+ sed -e "s@/bin/cat@$CAT@" -i config/auto-aux/sharpbang
+ '';
+
+ meta = {
+ homepage = http://caml.inria.fr/ocaml;
+ license = "QPL, LGPL2 (library part)";
+ desctiption = "Most popular variant of the Caml language";
+ };
+
+})