aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/core/tools/i3-rename.nix
/**    A utility to rename the current workspace
 *
 *  This tool relies on i3-input to change the name of the current
 *  workspace.
 */

{ pkgs, ... }: with pkgs; writeShellScript "libkookie-i3-rename" ''
  exec i3-input -F 'rename workspace to %s' -P 'New name: '
''