aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/shell.nix
with import <nixpkgs> {};

mkShell rec {
  name = "rstnode-shell";
  buildInputs = with pkgs; [
    rustc cargo clangStdenv rust-analyzer rustfmt

    # ggez dependencies
    pkg-config alsaLib libudev

    # librsvg dependencies
    glib cairo pango gdk-pixbuf libxml2

    
  ] ++ (with pkgs.xlibs; [
    # General opengl dependencies
    
    libGL
    libGLU
    libGL_driver
    
    libX11
    libXcursor
    libXi
    libXrandr
    libXxf86vm
    libxcb
    libxkbcommon
  ]);
  
  LD_LIBRARY_PATH = (lib.makeLibraryPath buildInputs);
}