summaryrefslogtreecommitdiff
path: root/metrics/Cargo.toml
diff options
context:
space:
mode:
authorhyperion <hyperion@spacekookie.de>2020-10-30 12:00:11 +0100
committerhyperion <hyperion@spacekookie.de>2020-10-30 12:00:11 +0100
commit857e0584d19e0abbc9f73a7ea9aea24be6a6786e (patch)
tree2ffbd6a261b00b6adfb148d458c6185a0ddf59a9 /metrics/Cargo.toml
parent43fc40d5dc18615aab9b99f940de59a8da20a902 (diff)
Refactoring repository structure and building basic nix module
Diffstat (limited to 'metrics/Cargo.toml')
-rw-r--r--metrics/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/metrics/Cargo.toml b/metrics/Cargo.toml
new file mode 100644
index 0000000..93ea887
--- /dev/null
+++ b/metrics/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "brook-metrics"
+description = "A server to handle brook metric reporting"
+version = "0.1.0"
+authors = ["Mx Kookie <kookie@spacekookie.de>"]
+edition = "2018"
+
+[dependencies]
+ratman-identity = { version = "0.5", features = ["random"] }
+chrono = "0.4"
+hyper = "0.13"
+json = "0.12"
+lazy_static = "1.0"
+
+#TODO: remove this when async-h2 comes out
+tokio = { version = "0.2", features = ["full"] } \ No newline at end of file